Private and Public feeds dead- Server upgraded? any getting feeds anymore?

Added by Hans about 7 years ago

Hi,
This weekend did public and private feed stop to output data to my application.
I noticed that explorer sequrity settings had to changed to support TLS1.0 to be able to reach this forum as well.
Same for www.nordnet.se

So i presume somehing was changed during the weekend, or ?

Rest service works as before. I tried to change the code to support TLS1.0 but no success (see below)

Nice with feedback if any have their SW getting those feeds and how their code is.

best regards

Hans

Public Function InitSslStreamClient(ByVal feed As String, ByVal machineName As String, ByVal serverName As String, ByVal iport As Integer, session_key As String, service As String, ByRef ssl As SslStream, ByRef feed_client As TcpClient, ByRef errmsg As String) As Boolean
' Create a TCP/IP client socket.
feed_client = New TcpClient(machineName, iport)
' Create an SSL stream that will close the client's stream.
ssl = New SslStream(feed_client.GetStream(), False, New RemoteCertificateValidationCallback(AddressOf ValidateServerCertificate), Nothing)
' The server name must match the name on the server certificate.
Try
'  ssl.AuthenticateAsClient(serverName)  <---------- worked before 18. august
ssl.AuthenticateAsClient(serverName, Nothing, SslProtocols.Tls, false)  '<- tried now- but dont work
return true
Catch e As AuthenticationException
If e.InnerException IsNot Nothing Then
errmsg = errmsg & vbCrLf & "Inner exception: {0}" & e.InnerException.Message
End If
feed_client.Close()
Return False
End Try

I send with
sslStream.Write(messsage)
sslStream.Flush()

and recieve with

bytes = sslStream.Read(buffer, 0, buffer.Length)


Replies (8)

RE: Private and Public feeds dead- Server upgraded? any getting feeds anymore? - Added by Hans about 7 years ago

Hi
i still see this problem, also when using old executables which worked perfectly before the 18. august

could anybody please try to use my account and try their sw to see if my account have a problem?

username: kepha
password for now: test

very grateful for feedback!

best regards

Hans

RE: Private and Public feeds dead- Server upgraded? any getting feeds anymore? - Added by Anonymous about 7 years ago

When I call subscribe my program fails.

{"cmd": "subscribe", "args": {"i": "40347", "m": 11, "t": "trade"}}

return m2.ssl_write(self.ssl, data, self._timeout)
M2Crypto.SSL.SSLError: (32, 'Broken pipe')

So I have the same problem as you do.

But it does seem like I get the lists. This works...
self.build_stocklist(self.req('lists/8')) #Large Cap
self.build_stocklist(self.req('lists/9')) #Mid Cap
self.build_stocklist(self.req('lists/10')) #Small Cap

So as I understand it it fails on the private part but the public information works.

RE: Private and Public feeds dead- Server upgraded? any getting feeds anymore? - Added by Hans about 7 years ago

Thanks a lot Joachim!

I phone Nordnet switchboard and they told me that the servers were upgraded during the weekend.

may be something there???

But the problem with the list command is something i have seen before, quite seldom, when i make a List or markets command.

I just wait a second and retry and then it is ok even if i send 10 commands at once. Happend perhaps evry 500 command.

That was the case until today,

I tested your List commands now and the error occured, then tried a lot others and at the 2. attempt on ticksizes did it work again.
then the error sporadicly happens.

I see the same problem with month old executabales which worked fine before thsi weekend,
Same error as you got + no privat and public feed.

Thus, seems that something happend over the weekend.

best regards

Hans

RE: Private and Public feeds dead- Server upgraded? any getting feeds anymore? - Added by Hans about 7 years ago

STrange,

suddenly did private and public feed start to work..

magic!

Thanks!

best regards

hans

RE: Private and Public feeds dead- Server upgraded? any getting feeds anymore? - Added by Hans about 7 years ago

Hi,

I still hevae the private and public feeds, but gets internal server error 500,
also with the months old executables, so still something strange in the system

best regards

Hans

RE: Private and Public feeds dead- Server upgraded? any getting feeds anymore? - Added by Hans about 7 years ago

Hi

This morning was the Public and private feeds dead again

best regards
Hans

RE: Private and Public feeds dead- Server upgraded? any getting feeds anymore? - Added by Anders almost 7 years ago

Jag har haft Hans fel hela tiden också, och idag är fortfarande alla feeds i test nere. Endast REST funkar.

Nu när Simon svarat i en annan tråd kanske någon är tillbaka från semestern och kan svara på alla obesvarade ärenden?

RE: Private and Public feeds dead- Server upgraded? any getting feeds anymore? - Added by Nordnet Simon almost 7 years ago

Hej, nu ska feederna fungera igen.

(1-8/8)