N00b-fråga

Added by Petter about 4 years ago

Hej,

hur vet jag om min test-account har approvats/har access till testsystemet? Reggade igår så jag antar risken finns att det ännu inte skett.

Om jag förstått det hela rätt är de account credentials jag skall logga in med desamma som för detta forum. Använder en moddad version (tar bort Jersey-dependencyn) av Java-klienten men får 401 som respons.


Replies (10)

RE: N00b-fråga - Added by Marcus about 4 years ago

Du får access till test-systemet direkt vid registering. Att du får error 401 som respons innebär att din request är "Unauthorized".

Mvh
/Marcus

RE: N00b-fråga - Added by Nordnet Simon about 4 years ago

Hej, du kan prova att logga in direkt på dokumentationssidan https://api.test.nordnet.se/api-docs/index.html . Det är samma username/password som till forumet. Det genereras en login till APIet och via dokumentationen kan du prova att göra anrop. När du sen har loggat in kan du prova att hämta dina konton i dokumentationen. Fungerar det så är ditt konto skapat.

RE: N00b-fråga - Added by Petter about 4 years ago

Hej,

jag provade inloggningen på manualsidan och den misslyckas också, med exakt samma username och password som funkar för forumet...

RE: N00b-fråga - Added by Petter about 4 years ago

Antar den kan hantera underscore i användarnamnet. Provade byta lösenord men samma resultat.

RE: N00b-fråga - Added by Petter about 4 years ago

Följande mening i dokumentationen är den som orsakade mig huvudbry: "When your account is approved you will also be able to use the same credentials for the public test system"

RE: N00b-fråga - Added by Nordnet Simon about 4 years ago

Ja - den meningen bör vi ändra - förut godkände vi användare manuellt men nu ska det steget ske automatiskt.

Jag kollar lite i loggarna och återkommer.

RE: N00b-fråga - Added by Nordnet Simon about 4 years ago

Petter wrote:

Antar den kan hantera underscore i användarnamnet. Provade byta lösenord men samma resultat.

Underscore ska fungera, men det går tyvärr inte att byta lösenord. Det slår inte igenom i test systemet utan bara i forumet.

RE: N00b-fråga - Added by Nordnet Simon about 4 years ago

Hej, jag såg en inloggning från dig 21:32 som fungerade. Det ser ut som om inloggningen kom via dokumentationssidan.

Vad ser du när du använder dokumentationssidan?

RE: N00b-fråga - Added by Petter about 4 years ago

Chrome har sagt "login failed" i en popup. Nu provade jag Firefox och den säger snarare ingenting. Sedan provade jag Chrome en andra gång för ikväll och det funkade då (ingen popup, "login successful" utskrivet under textfälten). Det skulle kunna vara browserspecifika buggar antar jag.

Trevlig midsommar!

RE: N00b-fråga - Added by Petter about 4 years ago

Allt funkar som tänkt nu (problemet i min klient var mismatch mellan PUT och POST) så ev. buggar är begränsade till dokumentationssidans testinloggning.

(1-10/10)