No orders in the test market?

Added by Andreas over 7 years ago

Hi,

This afternoon there are no live bid/ask prices in the test market (at least not for OMXS30 instruments). All price ticks look like this:

2011-09-28 16:37:05 - Incoming public feed of type price: {"cmd":"price","args":{"i":"992","m":11,"t":"price","trade_timestamp":"1970-01-01 01:00:00","tick_timestamp":"2011-09-28 16:37:05","bid":0.0000,"bid_volume":0,"ask":0.0000,"ask_volume":0,"close":198.80,"high":200.00,"last":196.80,"last_volume":0,"lot_size":1,"low":180.00,"open":200.00,"vwap":199.61,"turnover":155245359.70,"turnover_volume":777761}}

Is this correct? For sure, many instruments cannot be traded in the test market since there are no orders, but can it really be that the entire test market is empty?


Replies (6)

RE: No orders in the test market? - Added by Nordnet Simon over 7 years ago

Hi, this is not correct. We are looking into this.

RE: No orders in the test market? - Added by Nordnet Simon over 7 years ago

Hi, this is now solved.

RE: No orders in the test market? - Added by Andreas over 7 years ago

Good, thank you. I got the following strange message on the public feed around 12 today:

2011-09-29 12:10:08 - Unexpected error when handling PUBLIC feed. Message was: ":1,"low":81.85,"open":81.40,"vwap":82.03,"turnover":5874613.35,"turnover_volume":71605}}

Can it be that this had something to do with the fix? As you can see the beginning of the json message has been lost.

RE: No orders in the test market? - Added by Nordnet Simon over 7 years ago

It might, the feeds from NasdaqOMX started to work at that time (we also reloaded a lot of stuff and replayed the morning changes a couple of times before it worked).

But it looks strange. Can it be that you received more than 1 message in 1 TCP packet and this is the rest that you received in the next packet?

We always send 1 complete message and ends it with new line. But during load TCP and network layers can choose to split and merge the messages.

RE: No orders in the test market? - Added by Andreas over 7 years ago

No, I did not receive the beginning of this message. This partial message was indeed sent on one line. Even if it is split between TCP packets, I'm still waiting for a newline character, so that cannot explain it. I will keep my eyes open for something similar in the future. Did you see anything in the logs?

RE: No orders in the test market? - Added by Nordnet Simon over 7 years ago

I could not see any errors or warnings in the logs from 11:30 to 12:30.

We are not logging all the messages sent on the public feed only warnings and errors, so I can't see the actual message.

(1-6/6)