Feeds again

Added by Andreas over 7 years ago

The public feed seems to be down this morning:

2011-09-26 10:09:02 - ERROR - Feed was closed


Replies (7)

RE: Feeds again - Added by Nordnet Simon over 7 years ago

Hi, now it should be running again.

RE: Feeds again - Added by Andreas over 7 years ago

Still not working...
2011-09-26 16:55:52 - ERROR - Feed was closed

What was wrong the first time?

RE: Feeds again - Added by Nordnet Simon over 7 years ago

Hi, the first time I looked in the wrong place, sorry.

Now it should be up and running. This time I started a test client that enters 1 order per second and I receive orders and trades on the private feed. It has now been up and running for 10 minutes.

/Simon

RE: Feeds again - Added by Andreas over 7 years ago

It still doesn't work. Please note that the problems are in the PUBLIC feed.
2011-09-27 11:31:39 - ERROR - Feed was closed

RE: Feeds again - Added by Nordnet Simon over 7 years ago

Sorry again, I was looking in the private feed.

From our logs yesterday
=INFO REPORT==== 26-Sep-2011::16:45:10 ===
Authenticated 'XXXXX' for NEXTAPI <0.15475.423>
=INFO REPORT==== 26-Sep-2011::16:45:10 ===
User 'XXXXX' System 'NEXTAPI' <0.15475.423>
[...]
=INFO REPORT==== 26-Sep-2011::16:45:40 ===
<0.15475.423> disconnected (normal)

It looks like it disconnects exactly 30 seconds from the login (and it looks like the close down was initiated from the client - or the firewall).

If nothing arrived during that time we send a heartbeat. We had problems with the NasdaqOMX feed so the possibility that you got an heartbeat after 30 seconds is high (this can happen anyway in test since the volume might be low).

Can it be the heartbeat that is creating the problems?

If not I need to get help from the network/firewall guys to trace why the disconnect was initiated.

/Simon

RE: Feeds again - Added by Andreas over 7 years ago

Well, now it work just fine again. In my logs it looks like my connection is closed after about 10 seconds, and as far as I can see, it was not initiated on my side. Maybe some network timeout or something?

RE: Feeds again - Added by Nordnet Simon over 7 years ago

It might be the firewall/VPN thingy since no part initiated the close down.
Let me now if it occurs again.

(1-7/7)